Our server is currently running 2.0.2

I see there is a client patch up to 2.0.4

Do we need to upgrade the server before the client, or can the upgraded client still connect to the current server?

Thanks,

Alan