We're using the 4.38 iPrint client on XP. Back-end is currently NetWare 6.5.7

We're in the process of migrating to OES2 SP1 Linux (one "iprint server") done already.

Should we upgrade the client to 5.2 (or whatever it is) first and then the server?

Or does it really matter?