Hello,

I have a server with this configuration :

OES 2 SP1
Kernel 2.6.16.60-0.27-default
pure-ftpd-1.0.20-24.13
novell-lum-2.2.0.16-0.21

The ftp server was working fine for several months.

The problem is that ftp has stopped working suddently for 2 weeks now.

No configuration change have been made on the server.
The original configuration files was backed-up and restored but ftp is still not working.
The problem occurs either with eDirectory users and local users.

If I try to open a ftp connection I get this :

220-Welcome to Pure-FTPd.
220-You are user number 1 of 10 allowed.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
Name (servername.srv.vs.ch:root): localftp
331 User localftp OK. Password required
Password:
421 Service not available, remote server has closed connection.
ftp: Login failed.


If I try to open a ftp connection with a bad password I get this :

220-Welcome to Pure-FTPd.
220-You are user number 1 of 10 allowed.
220-This is a private system - No anonymous login
220 You will be disconnected after 15 minutes of inactivity.
Name (servername:root): localftp
331 User localftp OK. Password required
Password:
530 Authentication failed, sorry
ftp: Login failed.


If I try to open a ftp session from a dos command prompt :

331 User localftp OK. Password required
Password:
Connection closed by remote host.

Here is the (verbose) log on server side:

Aug 19 09:24:42 servername sshd[19101]: Accepted keyboard-interactive/pam for xxxxxxx from 192.168.1.199 port 4883 ssh2
Aug 19 09:25:35 servername pure-ftpd: (?@192.168.1.191) [INFO] New connection from 192.168.1.191
Aug 19 09:25:38 servername pure-ftpd: (?@192.168.1.191) [DEBUG] Command [user] [localftp]
Aug 19 09:25:41 servername pure-ftpd: (?@192.168.1.191) [DEBUG] Command [pass] [<*>]
Aug 19 09:26:48 servername pure-ftpd: (?@192.168.1.191) [INFO] New connection from 192.168.1.191
Aug 19 09:26:51 servername pure-ftpd: (?@192.168.1.191) [DEBUG] Command [user] [localftp]
Aug 19 09:26:53 servername pure-ftpd: (?@192.168.1.191) [DEBUG] Command [pass] [<*>]
Aug 19 09:26:53 servername pure-ftpd: (?@192.168.1.191) [WARNING] Authentication failed for user [localftp]
Aug 19 09:27:48 servername pure-ftpd: (?@192.168.1.192) [INFO] New connection from 192.168.1.192
Aug 19 09:27:48 servername pure-ftpd: (?@192.168.1.192) [INFO] Logout.


Any idea?? Thanks in advance.