I imagine, the cause for this trouble was, that I made several changes to the local
IP address of this server, to avoid duplicate IP during the cloning of this system
using Portlock Storage Manager.

Propably this messed up the sys:etc/hosts file:

The line with the IP and name of *THIS* server was spaceless concatenated with the
next line. is the correct IP. (16bit mask). It was modified using inetcfg to, and back to

The faulty line looked like this (the name of the server vanished completely): nw03 nw03.dns-name.com

Maybe this could help others.

NW6.5SP7, eDir 8.7

Regards, Rudi.


That's what I wanted to post prior catching the issue:

On one of "my servers" tomcat doesn't startup any more.

This is, what the logger screen presents:

tccheck: LDAP is not up yet; waiting
LDAP connectivity not found on ldap://localhost:636
Please load NLDAP and then manually execute command: sys:/tomcat/4/bin/startup
-config sys:/adminsrv/conf/admin_tomcat.xml
If your server host certificates have change recently, executing
sys:/system/tckeygen.ncf may be needed to restore secure LDAP
java: Class com.novell.application.tomcat.util.tccheck.LDAPVer ifier exited succe

Using Jarek Garow's LDAP browser, I *CAN* connect successfully to that server, also
tcpcon is displaying tcp:636 to be open for

Exporting the Host certificate from:localhost
Error importing certificate to keystore: sys:\adminsrv\conf\.keystore
com.novell.ecb.CommandException: localhost
at com.novell.ecb.security.RetrieveHostCertificates.r etrieveHostCertific
ates(Unknown Source)
at com.novell.ecb.security.RetrieveHostCertificates.e xecute(Unknown Sour
at com.novell.application.tomcat.util.EDirectoryInteg rator.retrieveAllHo
at com.novell.application.tomcat.util.EDirectoryInteg rator.performKeysto
at com.novell.application.tomcat.util.EDirectoryInteg rator.integrate(EDi
at com.novell.application.tomcat.util.EDirectoryInteg rator.main(EDirecto
java: Class com.novell.application.tomcat.util.EDirectoryInteg rator exited succe

loopback *is* corretly defined in sys:etc\hosts:

.... localhost lb loopback

and, uups: What happend to the server's own IP's entry in hosts? corrected, done. :)