Please be patient this is an involved tail... My configuration- ZCM10.2
running on SLES10SP2

A few weeks ago I was working with a Dell Mini 10 netbook and the found that
the network drivers would not load. Updating to the June 2009 driver update
for ZCM 10.2 took care of the problem, but I did notice that I was asked
about which network card (nic or wireless) I wanted to use for the imaging
process, but just selected the lan card and went on... Everything seemed to
work fine.

However, and this is the point of my rambling ...

Just the other day I needed to image a group of OptiPlex 960's in one of our
student labs. When I started the process using PXE I ran in a problem with
an interminably long wait for the imaging system to download from the
server. After about 5 minutes of waiting for about 1/3 of the imaging system
to download from the server I decided to give up and see what was wrong.
Since this is a relatively new server I figured it could be about anything -
something gone wrong with the server, communications to the lab or who knows

Anyway, just to complicate that situation, I had just been working with two
of the machines I now was having trouble with in my office (adjacent to the
server room) on some imaging issues and had noticed no problems with the
PXE boot process. I had also needed to replace the system board in another
960 just a couple of days ago and likewise had been working with that
machine - in my office - to debug the new image I was preparing for the
entire group of these machine. All in all I re-built that machine about 5
times to get the kinks out of the new image, and in all of that work I did
NOT notice any slowness in either the PXE boot process or imaging download.

Now I was faced with a couple of labs full of machines that could hardly do
a PXE boot, and at first glance the only change in the situation between
working in my office and in the lab was that the lab was 4 floors down and
at the other end of the building. - Maybe the bits were wearing out before
they got there.... Anyway, I downloaded the August 2009 driver update and
installed it on the server paying attention to modifications I might need to
make to the settings.txt file - NO IMPROVEMENT. I next made sure that all
patches had been applied to the server and did a full re-boot of the system.
STILL no luck...

I was just about ready to start in on the switch we have in the server room
when it occurred to me that the machine I had JUST been working on had a NEW
SYSTEM BOARD - AND - BIOS version A04. All the other machines had bios
version A01.

Updated the bios and all is well.

It appears that some change in the driver system from what came with ZCM SP2
and what was released with the June imaging update file (and continuing with
the August update) did not play well with the older Dell 960 bios. Also,
although I don't have any of them - a co-worker mentioned a problem with
OptiPlex 760's, and speed. I plan to talk to him and see if there is a
similar issue.