Have just started to deploy ZLM 7.2.1 and its not going so well. Client is RHEL4-WS

I created a trial RPM 'simple-test' , created a bundle (Simple Test Bundle) and assigned it to a workstation (sa-aifs224). So far so good, the rpm got installed.

Next I decided to test the "enforce persistance" by removing the rpm on the client machine
sa-aifs224# rpm --erase simple-test

However zmd did not restore the rpm like I was expecting.

Next I tried to update my bundle: I made an updated RPM (simple-test-1-2), added it to the "Simple Test Bundle" and removed the old version. This incremented the version number to 2 and I told it to deploy the new version immediately. This did not happen despite doing
sa-aifs224#rug clean-cache
sa-aifs224#rug refresh

Finally I tried to delete my bundle from the web-gui. Again this had no immediate effect so I left for the day.

Next morning I arrived to find that "Simple Test Bundle" had been deleted. I then re-deployed version 2 of my bundle to the client.

Now I find increasing numbers of
28 Aug 2009 14:20:20 INFO BundleTransaction Removed 'Simple Test Bundle-1'
entries in zmd-messages.log (I'm now seeing 30 or more of these each time the schedule runs)

However version 1 is still there
[root@sa-aifs224 ~]# rug bl

S | Catalog | Name | Version | Type
i | Mandatory Bundles | Simple Test Bundle | 1 | package
[root@sa-aifs224 ~]# rug bp "Simple Test Bundle"

S | Catalog | Name | Version | Arch
| Mandatory Bundles | simple-test | 1-1 | noarch

[root@sa-aifs224 ~]# rug info simple-test
Catalog: mandatory
Name: simple-test
Version: 1-1
Arch: noarch
Installed: No
Status: update available
Installed Size: 0
Summary: A simple RPM for test purposes
Description: This package is the simplest possible RPM, solely for testing.

Although its not actually installed on the client.
[root@sa-aifs224 ~]# rpm --query simple-test
package simple-test is not installed

So my questions are
1. How long should it take a bundle to be deployed when its marked for immediate deployment

2. How can I diagnose whats wrong with the agent that it keeps saying its removed the bundle when it hasnt

3. What can I check to see why the RPM didnt actually install.

4. What happened to version 2 of the bundle?

Any suggestions cheerfully welcomed.

I'm a newbie at ZLM so hopefully these are easy questions for you...