Home

Results 1 to 4 of 4

Thread: iManager cimom problem

Hybrid View

  1. #1
    Join Date
    Nov 2007
    Location
    Albany, NY
    Posts
    6,423

    iManager cimom problem

    Only thing that changed on my NW server was that I upgraded from eDir 8.7.3 10b to 8.8.5

    iManager 2.7.2 works fine, but when I try to perform DFS operations I get the infamous:

    Could not remove replica site SERVER.ABC from the management context. Cannot complete this operation: The connection is insecure. Make sure CIMOM is running on the server you want to manage, then try again..

    I know it's not the plugins/iManager because it was working. I checked and owcimomd wasn't running.

    I started openwbem.ncf and owcimomd.nlm wouldn't stay loaded.

    I enabled debug logging per other posting on the forums and I don't see anything "obvious" (other than the the error prior to debug logs)

    I'd post the log file, but it's too long.

    Only two items of "note" that I think are a bit odd:

    [1]* EXCEPTION CAUGHT IN CIMOM MAIN!
    [1]* OW_PosixFileSystem.cpp: 464 FileSystemException: Can't open random file for writing
    [1]safeLibCreate::create failed getting function pointer to "createProviderIFC" from library
    [1]Unable to load ProviderIFC library libnpiprovifc.nlm
    [1]NetWareAuthenticator: LDAP initialization complete
    [1]dlSharedLibraryLoader::loadSharedLibrary dlopen returned NULL. Error is: (dlfcn) No such symbol was found.
    [1]CIMOM failed to load indication rep layer library /system/cimom/lib/openwbem/libowindicationreplayer.nlm
    [1]* EXCEPTION CAUGHT IN CIMOM MAIN!
    [1]* OW_PosixFileSystem.cpp: 464 FileSystemException: Can't open random file for writing
    [1]safeLibCreate::create failed getting function pointer to "createProviderIFC" from library
    [1]Unable to load ProviderIFC library libnpiprovifc.nlm
    [1]NetWareAuthenticator: LDAP initialization complete
    [1]dlSharedLibraryLoader::loadSharedLibrary dlopen returned NULL. Error is: (dlfcn) No such symbol was found.
    [1]CIMOM failed to load indication rep layer library /system/cimom/lib/openwbem/libowindicationreplayer.nlm

    and this keeps repeating over and over:

    2009-09-09 17:36:24,990[2]Polling Manager: No work after 1 sec. I'm not waiting any longer
    2009-09-09 17:36:29,000[7]Polling Manager: Thread 0 is finished. Cleaning up it's remains.
    2009-09-09 17:36:29,000[7]Polling Manager: Work has been added to the queue
    2009-09-09 17:36:29,000[7]Polling Manager: About to start a new thread
    2009-09-09 17:36:29,000[7]Polling Manager: New thread started
    2009-09-09 17:36:29,000[2]Polling Manager: A thread got some work to do
    2009-09-09 17:36:29,000[2]CIMServer doing operation: EnumerateInstanceNames on root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:29,000[2]CIMRepository got class: CIM_EthernetPortStatistics from namespace: root/cimv2
    2009-09-09 17:36:29,000[2]CIMServer InstNameEnumerator enumerated derived instance names: root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:29,000[2]CPPProviderIFC found instance provider NetwareNetwork
    2009-09-09 17:36:29,001[2]CIMRepository enumerated classes: root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:29,001[2]CIMServer doing operation: GetInstance on root/cimv2:/root/cimv2:CIM_EthernetPortStatistics.InstanceID="1"
    2009-09-09 17:36:29,001[2]CIMRepository got class: CIM_EthernetPortStatistics from namespace: root/cimv2
    2009-09-09 17:36:29,001[2]CPPProviderIFC found instance provider NetwareNetwork
    2009-09-09 17:36:29,988[2]Polling Manager: No work after 1 sec. I'm not waiting any longer
    2009-09-09 17:36:34,004[7]Polling Manager: Thread 0 is finished. Cleaning up it's remains.
    2009-09-09 17:36:34,004[7]Polling Manager: Work has been added to the queue
    2009-09-09 17:36:34,004[7]Polling Manager: About to start a new thread
    2009-09-09 17:36:34,004[7]Polling Manager: New thread started
    2009-09-09 17:36:34,004[2]Polling Manager: A thread got some work to do
    2009-09-09 17:36:34,004[2]CIMServer doing operation: EnumerateInstanceNames on root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:34,005[2]CIMRepository got class: CIM_EthernetPortStatistics from namespace: root/cimv2
    2009-09-09 17:36:34,005[2]CIMServer InstNameEnumerator enumerated derived instance names: root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:34,005[2]CPPProviderIFC found instance provider NetwareNetwork
    2009-09-09 17:36:34,005[2]CIMRepository enumerated classes: root/cimv2:CIM_EthernetPortStatistics
    2009-09-09 17:36:34,005[2]CIMServer doing operation: GetInstance on root/cimv2:/root/cimv2:CIM_EthernetPortStatistics.InstanceID="1"
    2009-09-09 17:36:34,005[2]CIMRepository got class: CIM_EthernetPortStatistics from namespace: root/cimv2
    2009-09-09 17:36:34,005[2]CPPProviderIFC found instance provider NetwareNetwork
    2009-09-09 17:36:34,986[2]Polling Manager: No work after 1 sec. I'm not waiting any longer

  2. #2
    Automatic reply NNTP User

    Re: iManager cimom problem

    kjhurni,

    It appears that in the past few days you have not received a response to your
    posting. That concerns us, and has triggered this automated reply.

    Has your problem been resolved? If not, you might try one of the following options:

    - Visit http://support.novell.com and search the knowledgebase and/or check all
    the other self support options and support programs available.
    - You could also try posting your message again. Make sure it is posted in the
    correct newsgroup. (http://forums.novell.com)

    Be sure to read the forum FAQ about what to expect in the way of responses:
    http://forums.novell.com/faq.php

    If this is a reply to a duplicate posting, please ignore and accept our apologies
    and rest assured we will issue a stern reprimand to our posting bot.

    Good luck!

    Your Novell Forums Team
    http://forums.novell.com



  3. #3
    Join Date
    Nov 2007
    Location
    Albany, NY
    Posts
    6,423

    Re: iManager cimom problem

    opened an SR with Novell--we'll see what they find out.

  4. #4
    Join Date
    Nov 2007
    Location
    Albany, NY
    Posts
    6,423

    Re: iManager cimom problem

    I loaded the unixenv.ncf and ironically cimom stayed up

    Although I'd done that before and it didn't work (although I didn't try after I rebooted the server).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •