Hi All,
(Sure is quiet around here - must be because ZDM 7 is so stable...)

So I have been having inventory database issues. Random but inevitable
database failures - eg "assertion failed 201425" (and other numbers that I
cannot locate at the moment), "mgmtdbs.db is not a valid database file" on
starting the sybase database. Etc.

Long troubleshooting story short: it appears that the sybase.nlm application
cannot handle nss volumes that are large. In my case it fails if I try to
run it on a 3.6TB or 5TB volume, but succeeds if I run it on small volumes -
20GB to 65GB. Also the database was running fine on a 1.8TB volume - the
problems began when I virtualized the server (on ESX 3.5u4) and moved the
volume from direct-attached scsi storage to network-attached CoRAID (AoE)
storage AND expanded the volume to 3.6TB.

To test my theory I ran the database on two other servers and 3 other
volumes. In all cases success came when the hosting volume was small -
didn't matter if the host volume was direct attached or on a physical server
as opposed to a virtual server.

So if you are having inventory database problems, try moving the database to
volume that is small - I suspect the magic breaking point is 2TB which just
happens to be the maximum size of an NSS partition...and wasn't that also
the max size of an NSS volume sometime in the past? Maybe the sysbase
engineers were working in such an environment when they wrote the
nlm...after all it has been 4 years since it was last modified (I am running
v8.00.03, Nov 30 2005) and even longer since it was originally written.

Anyways, the reason it fails is not so important. There is a workaround and
a long term solution as well - move to ZCM 10.whatever-is-good ;-)


Ron Neilly
UBC Okanagan

PS If you have any evidence to back me up - or to disprove me - please