Sorry for posting again, but here is some more information, as well as some extra things we have tried.


The screen results with this exit code after the workstation has been imaged, prior to booting back into PXE and then re-imaging, along with completion and the same message.

================================================== ==================
Novell ZENworks Imaging Engine v10.2.0.0
© Copyright 1999-2009, Novell, Inc.
All rights reserved.

Imaging operation(s) assigned by
Elapsed time: 12:48
No more jobs to be done in policy

ZENworks imaging failed with error: 52.
Novell ZENworks SID changer for linux
Version — Copyright 2007 - 2009

Exiting: Computer has not been recently imaged

================================================== ==================

The above message occurs (and this happens to other Laptops & PCs) after the machine has been imaged, but we are still having the computer re-imaging itself, it is in a constant loop.

We were running Zenworks 7SP1 IR4. Last week we loaded Zenworks 7SP1 SR4.
My manager has rolled back to IR4, but no change, as we have computers constantly re-imaging over and over in a loop.

I have tried deleting the workstation object (name) from within ConsoleOne, and still the problem occurs. I have also made sure there are no add-on images attached to the imaging.

Now, whenever we image a PC, the imaging process appears to finish, but we get an error: "Zenworks Imaging failed with Error:52"
The system then reboots and starts the process again. If you look at the workstation properties, the Zenworks Image tickbox has not cleared, and hence the restart of the imaging.
I found that Zenworks error 52 is: "52 - No partition type given when asked to create a part". I don't know why it would be saying that. (It is also possible that this message has always been there, but we have never noticed it, as the process has always worked).

I came across an article that suggests the "ZENworks agent on the workstation has to be the same version as the ZENworks snap-ins in ConsoleOne".

We are using:
ConsoleOne Version 1.3.6h
ZENworks Desktop Management 7.0.1 = snap-ins for configuring policy settings
ZENworks Desktop Management 7.0.1 = snap-ins for administering and managing software distributions

If you have any ideas could you please let us know?

Cheers and thanks,