With our XP clients if we logon WS only and then try to map a drive to a novell server as long as the user name and password are the same for the windows and novell logon then the user isn't prompted for their password.

If I understand correctly (?) then this is Passive Logon. I can't get this to work in Windows 7. Logging on either locally or to a windows domain, if I then try to map to a novell drive I am always prompted for the password again, the user name is already filled in in the logon box.

I've added this registry keys from
[HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NWGINA] "PassiveMode"=dword:00000001
"PassiveModeNDSLoginSilent"=dword :00000001
"PassiveModeNDSLoginRequired"=dword: 00000001
This didn't make any difference though. I've tried it with the "novell logon" in Properties/Advanced Logon both on and off.
Any help you could give would be much appreciated, we want to bring out some Windows 7 PCs and allow them to connect to our existing novell drives but without users being asked for their password again.