Below is an example of an error I am recieving when using DLU on various devices.

Full Message: An internal error occurred while enforcing the "DLU - Volatile Power User" policy.
Additional Information: User creation fails
Severity: Error
Date: October 8, 2009 11:52:31 AM
Acknowledged Date: None
Source: /Devices/Workstations/Classroom Support/ht02
Message ID: POLICYHANDLERS.DLUPolicy.ErrorInEnforcement
Probable Cause URL: None
Log ID: ca650ba8d35db05a5a3008a353989c17
Related Objects: /Policies/Classroom Support/Dynamic Local User/DLU - Volatile Power User

Here is what is in the log file:
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [] [ContainmentRefresh] [] [Response : Novell.Zenworks.Zmd.ContainmentRefresh.GetContainm entResponse] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Time taken to get details from Containment Web service 63] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Time to set FullName and Description : 63] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Time taken for Eligible List : 63] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [GroupName in getLocalizedGroupName : Power Users, wellKnownGroup : 8] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Localized group name is 'Power Users'] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache done] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [ SavePreEnforceCurrentSessionSettings] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [ ConstructVersionDataDLU - Volatile Power User] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [ versionCacheDLU - Volatile Power User9] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [ PutVersionCacheData] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache done] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [isFirstLoginAfterPMR : False] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [DLUUserObjects UserNotExists : True] [] []
[DEBUG] [10/08/2009 11:52:31.000] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [DLUUserObjects UseAuthoritativeSource : True] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [User Account creation failed for : saschlic, retValue : 2245] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Exception in ApplyPolicies :
Exception Details: User creation fails
at Novell.Zenworks.PolicyHandlers.DLUPolicy.DLUUserOb ject.CreateUserAccount(String username, String password)
at Novell.Zenworks.PolicyHandlers.DLUPolicy.DLUUserOb ject.CreateUserFromAuthoritativeSource()
at Novell.Zenworks.PolicyHandlers.DLUPolicy.DLUUserOb ject.ApplyPolicies(MemoryData& memDataClass, _NWGINA_DLU_STATE_V1_& memoryMappedData, String sessionId)
at Novell.Zenworks.PolicyHandlers.DLUPolicy.DLUPolicy Handler.ApplyPolicies(ApplyPolicyRequest applyPolicyRequest)] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Inside Finally....] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [PutCache done] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Final status : 99999] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Time Taken to complete Apply Policies : 188] [] []
[ERROR] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [POLICYHANDLERS.DLUPolicy.ErrorInEnforcement] [An internal error occurred while enforcing the "DLU - Volatile Power User" policy.] [User creation fails] [3749d2d016febc10a4e496fc1769d757]
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Execute policy operation completed for policy type - dlu policystatus :Failure] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [the status returned is NoAction] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Setting handler completed to true.] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Checking to see if timer thread is still alive.] [] []
[DEBUG] [10/08/2009 11:52:31.125] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Timer thread is still alive. Aborting it.] [] []
[DEBUG] [10/08/2009 11:52:31.140] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [Timer thread aborted.] [] []
[DEBUG] [10/08/2009 11:52:31.140] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [calling CreateActionResult(CreateActionHandlerResult normal] [] []
[DEBUG] [10/08/2009 11:52:31.140] [1732] [ZenworksWindowsService] [54] [saschlic] [dlu policy] [] [UpdatePostActionRequest called time out is 5] [] []
[D

The devices are running XP SP3. ZCM is version 10.2.0.0. We have two application servers with tomcat tuned to 350 connections. We are utilizing an Oracle server configured to 1000 processes. We utilize ZCM to deploy group policy, DLU, and bundles to approximately 750 devices.

This error is occuring on various systems and I am trying to determine what may be the cause of this error. Does anyone have any idea how I might resolve this issue.

Thank you,
Michael Wolf