I ahve a test ZCM 10.2 Server running on SLES10.1.
It was installed fresh from the 10.2 iso.
I have the 10.2.1 update downloaded but When I attempt to Apply The Blue
Message Text appears saying that I must have Service Pack 2 for ZCM (
ZCM 10.2 ).

There is only 1 primary server in the test ZONE and techinically it
hasn't had the service pack 2 update applied as it was clean install of
SP2 but you would expect the update not to worry about that :)