Good afternoon colleagues, help me, please, in same issue.
There are different network printer connected to the network or through the built-in print server, or through D-Link DP-301U.
The problem with the printer HP 1120n, port USB to DP-301U.
We used a direct IP printing to the printer, and it works. There specified IP address, Protocol - RAW and Port 9100.
The aim is to configure all printers in a tree. Through iMenager, created all the printer.
When checking the printer, HP 1120n (USB) + DP-301U does not print through the iPint.
That is, in other words, IP printing works, and the printer is installed through the iPrint client does not print.
What did:
1. My driver, tried different versions of set.
2. My firmware on print server.
3. I tried all possible options in the print settings iMenager, nothing helps.
How it looks. After installing the printer through iPrint.
click "Test Printing", the job goes to print, the printer does not print.

For example HP 1522n (USB) + DP-301U - iPint print works, and HP 1120n (USB) + DP-301U - not work why?
Show me how to solve the problem?

Soft version
SLES-10-SP2 x64 + OES2-SP1b x64
novell-iprint-server 6.0.20081103-0.3
iprint-client WindowsXP 05.12.00