I recently updated our servers to ZfD 7 SP1, IR4, HP1 and an imaging script that I have used for all of the previous iterations has broken. It definitely worked with IR3a HP3 (2/2009).

For a number of reasons I need to do imaging manually (as opposed to PXE boot), so to save time I have set up the settings.txt file to run a script. This works so that when you choose 'Automatic', it will load the imaging engine then run the 'img' menu. I do the following

1. In settings.txt I modify the IMGCMD parameter at the bottom as follows:

export IMGCMD="runScript.s /bin/imgstart.s"

2. Then I put the file 'imgstart.s' file into the /addfiles/bin dir which is very simple. It is:

#Calls img immediately after bootup

This has worked flawlessly until IR4 HP1. Now when I do the above and boot from the CD after the imaging engine loads I get an error that says:

The script file does not exist as specified.

usage: runScipt.s scriptname
ZENworks imaging failed with error:8.
Please remove any floppies/CDs from the drive and press any key to continue

Notice that 'runscript.s' is misspelled. I think this comes from the help file. There is no 'runscipt.s' that I can find. It is 'runScript.s'.

Any thoughts about why this is happening?