We've been Netware customers for many years and have just bitten the bullet and purchased SLES/OES/Groupwise 8.

After extensive reading, i've managed to set up my server as follows:

Partition disk up - \ drive is 5GB, Swap File is 10GB and remaining partition is EXT3 + 460Gb. We have a 2Tb drive which we plan to put the GW on once we are in a position to format it all up and install realtime.

I have substituted our internet domain name to mycompany.net where appropriate in order to post this information publically.

Components Selected:

Apparmour disabled
Novell Backup/SMS
Novell Imanager
Novell Iprint
Novell DNS
Novell Storage Services
Novel Linux User Management (LUM)
Novell NCP Server/Dynamic Storage Technology

The change hostname via DHCP is unchecked
Server name is mail
Domain name is mycompany.net

IPV6 is disabled, as is Firewall
IP Addressing set as follows:
Static IP
DNS & ( is our current mail server & is our windows 2008 server)

I did not create a linux user, clicked next.

Tree name & context olsgw
Unchecked was Require TLS for simple binds

ConsoleOne & Groupwise Installation:

Groupwise installation copied to /usr/novell/sys/gw8 Console one was extracted from within this gw8 file structure and installed.

Groupwise installation file started, default folder for SDD selected. Linux mount directory /mnt
All software agents selected from menu.

After installing groupwise, consoleone is opened up and click on tools, groupwise utilities, create new system.

System name onlinegw
Primary domain oldegb
Domain directory /usr/novell/sys/gw8/gwsystem

Domain context olsgw
Post office directory /usr/novell/sys/gw8/gwsystem/post
Post office name pelham
Ip Address
Added user admin as a groupwise user

Installed GW internet agent, details entered for configure internet agent :
Server IP mtp 0
DNS Hostname mail
Send mail via relay (this is our existing mail server)
user@ mycompany.net
GW Domain Dir /usr/novell/sys/gw8/gwsystem
Default name gwia
LDAP Server port 389
Username/login cn=admin,o=olsgw
Internet Object Name gwia

Domain LDAP cn=oldegb, o=olsgw (I browse to select this)

Launch Internet Domain on startup

GWIA Config Options
Tools, Internet Addressing - create mycompany.net
Addressing Formats firstname.lastname@internet domain name

Ive checked the gwia.cfg file and the --home & --dhome are both set to /usr/novell/sys/gw8/gwsystem/wpgate/gwia

We are certainly lacking knowledge of DNS unfortunately - I have created a port forward on our router to route traffic received on port 25 to forward to (port 25). We purchased a .net from LCN, the DNS Records entered on their website are:

Mail Server Records (MX)
mycompany.net. - Priority 10

A Record Hostname: www
A Record IP Address 86.xxx.xxx.xxx

No other information has been entered for DNS records on their site, the dnsgoodies website however reports this:

No 'A' Record Found
MX 10 mycompany.net.


ns0.lcn.com.mycompany.net. hostmaster.lcn.com
1 28800 7200 604800 86400

I have just tried sending an external message to a users address in the GW address book and it bounces back with the following error:

Host or domain name not found. Name service error for name=mycompany.net type=A: Host found but no data record of requested type

We are unable to ping the hostname of the server machine from existing windows clients or see the fully qualified domain name for the server (mail.mycompany.net). We had been unable to telnet to port 25 but have just discovered some additional information in that the postfix module may need to be disabled otherwise there is a conflict. I have issued the commands /etc/init.d/postfix stop & chkconfig postfix off and can now successfully telnet to port 25.

I have interrogated the Internet agent by changing to /opt/novell/groupwise/agents/bin & typing in ./gwia --show @gwia.cfg & - the system is running.

In the Novell DNS Servers module, i have created under dns zones a master record mycompany.net, the MX record component points to mail.mycompany.net with a priority of 10 and there is a Records key of mail. 'A' with a Value of

Any pointers or advise would be gratefully received.