Hi guys,

"As the tree said to the lumberjack, i'm stumped".

Something is going on here that has me completely stumped as to how to fix it. A bit of background... I'm building a SOE for our new desktop computers, XP with SP3 and we've already purchased the new desktops, which are Dell Optiplex's and I built the new SOE first by slipstreaming SP3 into our XP install CD, installed the required apps, tested that they all ran and everything was looking good. For operational reasons we are going with XP + SP3 as our new SOE. Did a test rollout to 8 users and discovered an application problem with our document management system, which, after weeks and weeks of troubleshooting with the vendor, turned out to be related to SP3 not installing terminal services when slipstreamed into the XP disk this software has a dependency on one of the terminal services DLL (that isn't mentioned in its release notes, however).

So last week when this was discovered I went back to the start, installed XP with SP2 from our original disk, manually installed SP3, then all the available windows updates, installed the applications, tested that the troublesome application works (which it did) and started cleaning up the install for sysprep and imaging.

Once sysprepped I took an image of the machine using Novell Zenworks Imaging (FYI it works very similarly to Ghost) and then deployed it and the add-on Zenworks images which are required for the SOE. Once that all completed I expected the machine to come up with the mini-setup part that I'm used to and be ready for user testing (this was on Monday). Unfortunately, the machine has blue-screened as windows was loading for the first time.

Being the smart cookie that (i like to think that) i am, I took an image of the machine as it stands before sysprepping it in case it turned out that I needed to change something in the sysprepped image that was revealed in user acceptance testing. So I rolled back to this image and changed the option to automatically restart on BSOD, re-sysprepped the image and took another image. Same result but now I know what the blue-screen is saying. It's a stop error 0x00000024 which seems to be related to NTFS.SYS so using ImageExplorer (similar to GhostWalker but for Novell Zenworks Images) I took a working NTFS.SYS file out of a working image (the previous image I had created which had the application problem) and updated the image file with a working NTFS.SYS. Unfortunately this has had no effect I'm still getting the same BSOD after everything completes.

I thought this could be to do with the sysprep options i've been using (use mini-setup, detect nonPNP hardware, reseal) so I tried without detecting nonPNP hardware. No change...

So I tried using a different program to do the imaging - and it seemed to work ok, which leaves me pointing the finger at Zenworks for causing this particular issue (which is weird since in the first lot of images it worked a treat). A bit of searching showed me a link to the SP1_IR4a_HP1 patch which I've since applied to our SLES10/OES2 server and taken everything back to the pre-sysprepped image, sysprepped it and then applied the image again, only to have it bluescreen with the exact same BSOD message.

Can anyone suggest what might be causing this? Should I log a support call?