I have an issue with one specific workstation model running Novell Client 4.91 SP5 and ZEN agent v. where the workstations will BSOD intermittently. I have other models using the same NC and agent version that do not have this issue.

A workstation may be fine for a few days then the BSOD will reapprear, and the stop codes vary. I've seen:

Stop: 0x000000D1 (0x80000060, 0x00000002, 0x00000000, 0xF8484507)

Stop: 0x000000C5 (0x00000004, 0x00000002, 0x00000001, 0x805515A1)

Stop: 0x0000000A (0x00000000, 0x0000001C, 0x00000001, 0x804E163C)

Stop: 0x000000D1

Stop: 0x00000050 (0xC2FCF1EC, x00,

Stop: 0x0000000A (0xE0822171, 0x0000001C, 0x00000001, 0x804E163C)

Stop: 0x00000019 (x20, 0xE17953A1

Stop: 0x0000008E (0x0000001D

Stop: 0x0000004E (0x0000008F, 0x00001147, 0x00001167, 0x00000000)

Stop: 0x0000001A

Stop: 0x00000024 (0x001902FE, 0xF8BA0434, 0xF8BA0130...)

Sometimes a specific driver is referenced (afd.sys, ntfs.sys, win32k.sys) sometime not. This started when I rebuilt the image (a fresh XP install with SP3), which I also did with the other models we have. I've followed the usual troubleshooting steps like "remove any new hardware", "uninstall any new software" etc but since the software is all new (though most of it was in the last image) and I didn't see the issue while building the image, narrowing it down to a particular piece of software is difficult.

I also know that if I uninstall the BroadCom NetXtreme Gigabit NIC the issue goes away, but I've tried the latest drivers on Acers site (Veriton 3600GT), as well as directly from BroadCom but the BSODs still happen.

When I enabled Driver Verifier to force a BSOD, I got a Stop: xE3; when I googled this I found similar cases and in one case MS KB971486 was uninstalled to fix the issue. I did this to my image and it was good for 2 days, I thought the issue was resolved but then they started again.

With KB971486 uninstalled Driver Verifier brings a stop: xC4, always the same, which doesn't really tell me much. I've used WinDBG to debug a full memory dump and this points to nicm.sys (v3.0.0.5), which from what I can find is part of Novell XTier Services. Is this part of ZEN Middle Tier?

I've applied the following client SP5 patches:

- Novell Client 4.91 Post-SP5 NWFILTER 1
- Novell Client 4.91 Post-SP4, SP5 NWFS.SYS 6
- Novell Client 4.91 Post-SP5 Login Files 5
- Novell Client 4.91 Post-SP4, SP5 SRVLOC.SYS
- Novell Client post-4.91 SP5 NOVNPNT

I've tried disabling the Novell XTier Agent Service, but using a free program called ServiWin (v1.37) I can see that nicm.sys is still loading on startup. Updating to ZEN agent v. didn't help, still I get a xC4 when I re-enable Driver Verifier.

I haven't tried deleting C:\Windows\System32\Drivers\nicm.sys, or reinstalling the Novell Client and Post-SP5 patches, but these are next on the list.

Does anyone have any ideas, I'm running out myself...