Dear Forum,

since we updated our Citrix machines with the 10.2.1 Agent (it was the same on 10.2.0) users are very often getting no icons in their launcher window. It's something about 10% of the Users every morning calling us. The Users are logged in correctly, but they have no bundles or policys showing up, when I open the properties of the agent.

We tried to do a manual refreh - no effect
We tried logging of and on the user in ZENWorks manually - no effect
We tried logging of and on the user from the Citrix Server - no effect

Only when we are locking the Citrix machine, so that the session is forced to use another machine we can get the icons for the user back.

We don't have a directly corresponding error message to this. Not in ZCC and not zmd-messages.log. But sometimes we have a

POLICYHANDLERS.CommonClasses.HandlerTimedOut{launc her configuration policy}

Our GINA configuration on the Citrix machines is:
CTXGINA=Renamed nwgina

Are there otherones having similar problems? Any ideas to this? The only idea we have is reverting to 10.1.3 Agent that worked much better on our Citrix machines.
Does other