Howdy ,

( reason for my migration is speed of Linux and slightly damaged edir , so in this scenario i also have created a new tree!)

After browsing around because i bumped into the c06b error when trying to load the poa on linux i was suprised that there was little or no information around to upgrade to linux with libraries .. apart from the check in check out options .. which actully works ...but safety of documents id thought id post the way we did it to spare people the check in check out option and just migrate to full :)

In my company there are 30+ libraries stored on the same server .. residing outside our poa , on the same disk system but not within the poa ..

* old system * NW6.5 SP8 / GW 7.03 (tree 1 )
WEBACC (\\SERVER\VOL\grpwise\dmn\web)
GWIA (\\SERVER\VOL\grpwise\dmn\gwia)
POA &MTA (\\SERVER\VOL\grpwise\poa) (\\SERVER\VOL\grpwise\mta)

Remote storage area's
(\\SERVER\VOL\grpwise\poa\lib2) etc etc

migrating all this to
* Linux OES2 SUSE10 (tree 2 )
7.03 / 8.0 agents installed ( default location)


so keeping my structures basicly the same..

Now for the basic file transfer we decided to go with Rsync .. , this gives us time to copy while on production and resync when we want to have a freeze point to actually go live on linux, whitout disturbing production.

during this rsync , we created a new tree and created all the users inside the new tree , reinstalled zenworks etc etc ..

so tree2 was tested with login scripts etc while the rsync was copying data from the old NW server to the New LNX server.

once rsync was done we grafted the groupwise objects into the new tree (LINUX)once in the new tree the paths of the remote storage area's has to be set then a rebuild of the poa is prefferred .. however here's 1 catch
all the files are still UPPER and LOWER case , u need to correct this (ON LINUX).. there are scripts around .. after correcting this .. we tried to load the poa .. no success .. ( changed UNC paths from console one windows, also added the native linux path to match our newly system )

c06b ( ran gwcheck .. same result)

so we setted up a new netware server in the new tree .. resynced to that server , regrafted the lot again .. ( gwagents installed )
modify the storage area paths again .. and it loads .. ON netware 6.5 sp8 ..

from this point we tried the migration tool to merge it into linux ( since we want a new tree .. and im quite certain it doesnt migrate trees .. )
we had to set up the netware box ( once again not to disturb production )
only this time using the migration tool .. ( since the data was present on the lnx server migration took 2 hours ) however when completed ... no poa on linux .. c06b error ..gwchecked again .. same result ..

so then we tried loading the poa on the netware box with the storage area's on linux( once again modifying the paths in console one/windows )
it worked .. my new netware box was running storage area's on linux .. without errors on the netware poa .. so there has to be something off .. don't you think ?

so proven that the netware server can load the storage area's of the linux server ( in the same tree ... this was my fall back if linux failed to migrate)

however still no poa agent with libraries on linux .. here's the sollution

install console one on the LINUX server with gw snapins .. ull notice that all the storage area's UNC paths have changed .. this is incorrect.. u have to modify the UNC path to the native linux one .. and u have to do this on the linux consoleone version ..

console one windows UNC path of the storage area looks like this


when loading LINUX consoleone UNC looks like this

/media/nss/VOL/SERVER/VOL/POA/LIB or similar my case this should be:


u can verify this by bringing up your new POA on linux with NOCFG
( be sure to make changes to the MTA /PORTS ETC, so it can communicate with the poa ! )
modify the paths in linux console one and watch the magic ,,,ull notice that if u access the library ( poa loaded with show :) ) and the path isn't modified correctly the c06b error pops over ..

Give it time to update though ..

after that u can launch your new POA from the console without NOCFG

and every works nice and dandy !