Ok, so I'm in the process of moving from a single domain / single po system here to a two domain system, as part of a virtualization process.
So I've created two extra domains on two new hosts.
I've created samba shares for these domains.
I've created a mount point for them (and mounted them as root).

I've created a new postoffice under one domain, and I've moved the users and the library there. Worked very nicely.

For some reason, the two new domains claim that each other is down.
The original domain sees them as up.
I've gone through the link configuration, and it seems to be ok.
I still get mail routed from them, but I suspect they are routed via the third domain???

So to get rid of that problem, I tought, well, the gateway domain is easy to reinstall, so let's just get rid of that, and I'll just recreate it.

So I removed the GWIA and Webaccess objects, as well as the MTA from the edir.
But when I tried to remove the domain, it claimed that there were still subordinate groupwise objects.
Looking at the groupwise view I can see the mta. If I try to remove it from there, it tells me that the edir counterparts are gone, and if I want to retry removing them. When doing that, nothing happens.
I can see in the 'Pending Operations' that the delete sits there.

So, I'm a bit lost on what to do now, any constructive input is appreciated.