Apple have now released 10.6.2 so anyone having problems accessing
NetWare or OES2 SP1 (or SP2 when released) Linux servers via AFP from
Mac OS X 10.6.0 or 10.6.1 should update.

See http://support.apple.com/kb/HT3874 which specifically includes

Network file systems fixes provided for:
* compatibility with third-party AFP servers

Download from http://support.apple.com/kb/DL959

If your servers are NW6.5 SP8 or OES2 SP1 then I would also advise
applying the Mac 10.6 FTF patch to catch any Macs that haven't been updated.

HTH.
--
Simon
Novell Knowledge Partner (NKP)

------------------------------------------------------------------------
Do you work with Novell technologies at a university, college or school?
If so, your campus could benefit from joining the Novell Technology
Transfer Partners (TTP) group. See www.novell.com/ttp for more details.
------------------------------------------------------------------------