I just installed a brand new SLES11 64bit server (VMware guest).
Installed the ZLM agent on it, registred it to the ZLM server and ran the updates from it. So server fully patched.

Installed ZCM
-Installed mono
-Installed ZCM 10.2

After install novell-zenagent won't start.
Did some troubleshooting and found:
server:/ # /opt/novell/zenworks/bin/ZenLinuxDaemon --debug

** (/opt/novell/zenworks/bin/ZenLinuxDaemon.exe:11374): WARNING **: Symbol file /opt/novell/zenworks/lib/mono/2.0/mscorlib.dll.mdb has incorrect version (expected 50.0, got 39)
Corlib not in sync with this runtime: expected corlib version 68, found 60.
Loaded from: /opt/novell/zenworks/lib/mono/2.0/mscorlib.dll
Download a newer corlib or a newer runtime at Mono Daily Binary Packages.

And then:
server:/mnt # rpm -qf /opt/novell/zenworks/lib/mono/2.0/mscorlib.dll
saturn02:/mnt # rpm -e novell-zenworks-mono-1.2.6-0.0.0
error: Failed dependencies:
novell-zenworks-mono is needed by (installed) zmd-
saturn02:/mnt # rpm -e novell-zenworks-mono-1.2.6-0.0.0 zmd-
error: Failed dependencies:
zmd is needed by (installed) novell-zenworks-zmd-tess-7.3.1-0.0.0.x86_64
zmd is needed by (installed) novell-zenworks-zmd-policymanager-7.3.1-0.0.0.x86_64
zmd is needed by (installed) novell-zenworks-zmd-settings-7.3.1-0.0.0.x86_64
zmd is needed by (installed) novell-zenworks-zmd-policyenforcers-7.3.1-0.0.0.x86_64
zmd is needed by (installed) zmd-inventory-
zmd is needed by (installed) zen-updater-7.3.1-0.0.x86_64
zmd is needed by (installed) rug-
zmd is needed by (installed) novell-zenworks-zmd-gconfpolicyenforcers-7.3.1-0.0.0.x86_64
zmd >= 7.1.1 is needed by (installed) novell-zenworks-zmd-imgagent-7.3.1-0.0.0.x86_64
zmd >= 7.1.1 is needed by (installed) novell-zenworks-zmd-rmagent-7.3.1-0.0.0.x86_64
zmd is needed by (installed) novell-zenworks-zmd-actions-7.3.1-0.0.0.x86_64


So went back to the VMware snapshot I made after installing the ZLM agent, uninstalled it.
Reinstalled ZCM and now the novell-zenagent starts!

I also tried updating mono to the newest version, but then the agent complains mono is too new.

Are they really incompatible, or is there a trick to it?