We have at least 5 different HP pc models that work with ZCM10 SP2 imaging in the organization, but we have a problem with all our HP Mini 5101 regarding PXE boot.

There is no problem booting on the network adapter manually (F12 at bios) and performing maintenance imaging. However if we set the HP 5101 up for deployment, e g the network adapter as 1st boot device, and hard drive as 2nd the problem occurs.

PXE boots fine, and hands over to Novell Zenworks PXE Agent v10.2.0.0. If there is no job to perform the PXE Agent exits as it should, with the message "PXE-M0F: Exiting PXE ROM.", gives a blank screen with a blinking underscore cursor. The disk activity LED flashes one time briefly stops. Boot halts.

I have tried several HP Mini 5101, straight from factory and also a machine that I have installed manually from official Windows XP SP3 install cd. They all show this problem.

I am not sure, but it seems to me that the Novell PXE Agent possibly is at fault.

  • We use imaging with ZCM 10 SP2 on SLES 10 SP2.
  • ZCM 10 SP 2 is updated with PRU for November.
  • Tried field patch ZENworks Imaging Driver Update for November 2009
  • The PXE on the network adapter is Yukon PXE v6.23.1.3 (20070906).
  • I have not found any BIOS update for the HP Mini 5101.
  • I have not found any update from HP for the network adapter.
  • I have found an update from Broadcom for the network adapter, but the PXE version is the same as the one shipped, Yukon PXE v6.23.1.3 (20070906).