I have one device which has problems to install some vulnerabilities:

i.e. The Microsoft .NET Framework 2.0 SP2 (all. lan.)
The error ist

[12/08/09,09:08:49] Microsoft .NET Framework 2.0a: [2] Error: Installation failed for component Microsoft .NET Framework 2.0a. MSI returned error code 1603
[12/08/09,09:08:52] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0a is not installed.

The Other Problem deployments are:
Microsoft .NET Framework 3.5 SP1
MS 940289 (German) Office Compatibility Pack Service Pack 1
MS 953331 (German) Office Compatibility Pack Service Pack 2 (Rev 2)
MS08-069 955218 951550 Security Update for Microsoft Office 2007/Expression Web (All Languages)
MS09-061 974378 953300 974291 974292 Security Update for .NET Framework 2.0 SP1 and 3.5

One of them give me the error, that the Updatedatebase is not OK.

All the other devices works wothout problems.