IPP Error: 0x500 when creating a Printer Agent

I appear to be affected by this bug, unfortunately by the second senario, NCS and iPrint together. It says to find a RPM older than 20090917, problem is where do I find them, I've only ever installed and updated iPrint via yast. Sorry if this isn't the right place, figured I'd find other iprint users that have had to do this.