We got an email from a security notification thingy about iPrint client having issues.

They say to use 5.32, but I don't see that on Novell's download site, only 5.30

Here's what the email says:

5) CRITICAL: Novell iPrint Client Multiple Buffer Overflow Vulnerabilities
Affected:
Novell iPrint Client 5.x

Description: Novell iPrint is a network printing system for multiple
networks and operating systems. Two vulnerabilities have been reported
in Novell iPrint Client and they can be triggered by a specially crafted
web page. The first issue is a stack-buffer overflow vulnerability
caused by an error in "ienipp.ocx" while parsing "target-frame"
parameter. The second issue is a buffer overflow vulnerability caused
by an error while parsing certain time related information. Successful
exploitation in each of the cases might lead to arbitrary code
execution. Some technical details for the vulnerabilities are publicly
available.

Status: Vendor confirmed, updates available.

References:
Secunia Security Advisories
Vulnerabilities - Secunia Research - Vulnerability Information - Secunia.com
Vulnerabilities - Secunia Research - Vulnerability Information - Secunia.com
Vendor Home Page
NOVELL: Worldwide
SecurityFocus BID
Novell iPrint Client Remote Buffer Overflow Vulnerabilities