I know that Windows 7 (and most likely Vista, which I've never touched - oh
I take that back - our foreign exchange student had Vista on her notebook,
and I had to figure out how to map a drive on it - in Italian!) has all of
this "security" that is supposed to keep us safe from the outside world.
Apparently it's supposed to keep us safe from ourselves as well!

Here's what I ran up against today, and I just don't understand it.

1. Daugher's XP machine was converted to a VM with the VMWare Converter -
it now resides on her D: drive.
2. New installation of Windows 7 on her PC (C: drive).
3. Want to copy files from old WinXp to new Windows 7 - specifically from
the Program Files directory

So, I first tried to just map a drive to \\ipaddress\c$ from WinXp to
Windows 7 - it would not work. Tried the same from Win7 to WinXP - also no
go - it's "Home" edition on both, and if I remember correctly WinXP home is
weird when it comes to Windows networking anyway.

Created "shares" of the C: drives on both machines - so from Windows 7 I
could map to \\ipaddress\xp-c and from XP I could map to \\ipaddress\win7-c

I was cooking! Last night I managed to copy all of her iTunes setup to the
new computer, which made her happy, because all of her playlists, etc. were
intact, and I thought "this won't be so bad".

However, I today tried to copy from c:\program files on XP (World of
Warcraft of course) to c:\program files on Windows 7 from the XP box - no
go. Just an "access denied" error. This was mapped FROM XP to Windows 7.

So, I logged into the Windows 7 PC as administrator, mapped the drive to XP,
and tried the same copy - access denied! I disabled UAC - still no go. I
swung a dead chicken over the PC - nothing! No matter what I tried, I could
not copy that World of Warcraft directory to the Windows 7 PC. I even tried
to copy it just into the "User" directory first - access denied.

At one point, I got it copying from the XP box to c:\users on the Windows 7
box - this was FROM XP. But then I got the dreaded "Not enough server
storage is available to process this command" and the drive mapping was
dropped about 2 GB into the 20 GB copy. I never managed to get that XP box
attached back to the Win7 every again. I found some info on this, but just
haven't had time to "fix" it.

Anyway, I finally got the files copied - I just copied them up to the OES2
server (NCP) and then back down to the Windows 7 box (NCP) right into the
Program Files directory without any complaints at all. Used robocopy and it
was fast and "easy". So it seems to be totally "Windows networking"
related, and not really rights on the Windows 7 PC at all - I mean if I can
get it to copy by bypassing Windows networking, but not with Windows
networking it has to be something in the Windows networking that I've messed

Sowhat SHOULD I have done that I didn't do to just make it so that I could
copy a directory from WinXP Program Files to Windows 7 Program Files? WoW
is one of those unusual programs anyway that actually just lets you copy
things over and actually WORKS without a new install. I'm not sure I"ll
ever have to copy anything into Program Files again <heehee> - but the whole
procedure just made me want to throw that PC out of the window (which would
have managed to get rid of both of them, since the VM is on the D: drive


Novell Knowledge Partner
Moving GroupWise to Linux?