Got GW8 up and running and also found the new C1 works with Windows 7. However I get an error every time I open it that says:

To avoid problems with database integrity, please disable File Caching and enable File Commit in the Novell Client settings

I have done that, restarted, but still get the error. Strange.