Hi all!

At first we tried a SLES server running ZenWorks 10.2. The application
migration was a complete mess (practically none of them worked), and
the integrated Sybase10 database kept hogging the CPU. I first took a
look at the situation in August--a google search revealed some postings
that acknowledged the problem and suggested using a "real" database
instead. So, I installed Win Server 2003 with SQL 2005 in a VM, and did
a clean re-install of ZCM10.2 on that. That's as far as I got, as there
were other priorities.

Fast-forward to last week.

I did an app migration, deployed the adaptive agent to a test
workstation, and it promptly blew up in my face: the only apps that run
are dirt simple; nothing substantial would deploy. If I associate the
wrong app(s) with the workstation, the adaptive agent will eat between
100-400MB of RAM while processing it over the course of 10-30 minutes.
The log file is stuffed full of the GUIDs for apps the agent didn't

I upgraded to 10.2.2, figuring it was worth a try. I deleted all the
apps and tried again with the new migration tool. Same results. I found
the preference setting that seems to enable migration as .MSI packages,
and got slightly better results. Few apps deploy properly, fewer still
quickly, but at least I haven't seen the adaptive agent completely lock
up this time 'round.

App migration worked flawlessly in my test environment. I should note
that most of the 140+ apps we need to migrate are snapshots, quite a
few dating back to very early versions of Zen.

Has anyone else run into this sort of situation? Any suggestions on how
to proceed? We would really like to avoid manual repackaging.


Tom Stowell