I am trying to read an image that I created in April 2009. I used it in August 2009. An now I am receiving the error - This version of the imaging engine cannot read this image.

I have recently upgraded the image engine to v7.0.1.7 and threw out old copies of boot disk, etc. Is my problem that it was written with an older version (no earlier than 6.5)? Or is it something else?