I was reinstalling Win2003 server on a HP ML110 G3 yesterday and had a
couple of ridiculous problems.

Connected PS2 keyboard and USB mouse to server.
Interrupted the start up by pressing F8 to configure the RAID array.
Booted from the install CD. Pressed F6 to install disk controller drivers,
selected them OK.
Got to the licence agreement where I needed to press F8 to accept, and the
F8 key wouldn't work!
Shut down, added a USB keyboard and tried again. F8 on PS2 keyboard still
not working but worked from USB keyboard.

Later in the install, got the usual warnings because RAID controller drivers
not signed. Clicked on button to continue for the first two instasnces
without a problem. The third time I was pronpted the USB mouse did not
respond. Also both keyboards would not respond.
Powered off, added a PS2 mouse, and tried again. Same behaviour from the
original mouse and keyboards, but at least the PS2 mouse worked this time.

In times past I would have asked "Why?", but I now I don't care.