I just installed ZENworks 10.2.0 fresh on a Windows Server 2003 box. I then tried to update it to 10.2.2, but it keeps failing, just like the old install did.

Set logging to debug, found this in the zmd-messages.log
Code:
Novell.Zenworks.SystemUpdate.SystemUpdateModule.getUpdateContent(AssignedSystemUpdatesResponseAssignedSystemUpdate update, String commandLocation)] [] [] 
 [DEBUG] [01/21/2010 14:42:14.423] [1152] [ZenworksWindowsService] [49] [] [SystemUpdateModule] [] [Unexpected error occured during system update
Type: Novell.Zenworks.Content.Exceptions.InaccessibleContentException
Message: Content id e532e8474e53ff685e590a8f6d3e1dfd is inaccessible
Stack Trace:
       at Novell.Zenworks.Content.Internal.CacheProxy.PutContent(ContentInfo contentInfo, Progress progress, Boolean bypassThrottle, Int64 priority)
       at Novell.Zenworks.Content.ContentManager.Novell.Zenworks.Content.IContentManager.DistributeContent(String contentId, Progress progress, DistributionFlags distributionFlags, Int64 throttlePriority)
       at Novell.Zenworks.SystemUpdate.SystemUpdateModule.getUpdateContent(AssignedSystemUpdatesResponseAssignedSystemUpdate update, String commandLocation)
       at Novell.Zenworks.SystemUpdate.SystemUpdateModule.runInstallCommands(AssignedSystemUpdatesResponseAssignedSystemUpdate update)
       at Novell.Zenworks.SystemUpdate.SystemUpdateModule.ApplyUpdate(AssignedSystemUpdatesResponseAssignedSystemUpdate update)

] [] [] 
 [DEBUG] [01/21/2010 14:42:14.423] [1152] [ZenworksWindowsService] [49] [] [SystemUpdateModule] [] [Attempting to update device's update status for update 50100202008b93e7d3949f03b6fb5eb5 to ERROR] [] [] 
 [DEBUG] [01/21/2010 14:42:14.454] [1152] [ZenworksWindowsService] [49] [] [SystemUpdateModule] [] [Successfully updated device's update status for update 50100202008b93e7d3949f03b6fb5eb5] [] [] 
 [DEBUG] [01/21/2010 14:42:14.454] [1152] [ZenworksWindowsService] [49] [] [SystemUpdateModule] [] [Update failed to apply: Update for ZCM (10.2.2) (50100202008b93e7d3949f03b6fb5eb5)] [] [] 
 [DEBUG] [01/21/2010 14:42:14.454] [1152] [ZenworksWindowsService] [49] [] [SystemUpdateModule] [] [Update uid matches the originally scheduled update, or is the superceding update] [] [] 
 [DEBUG] [01/21/2010 14:42:14.454] [1152] [ZenworksWindowsService] [8] [] [SystemUpdateModule] [] [Starting update: 50100202008b93e7d3949f03b6fb5eb5] [] [] 
 [DEBUG] [01/21/2010 14:42:14.470] [1152] [ZenworksWindowsService] [47] [] [SystemUpdateModule] [] [Starting update: 50100202008b93e7d3949f03b6fb5eb5] [] []
Anyone have any ideas?