We have a problem with our BM3.8 SP3 box, in that every time we change a
filter, it says "Could not open file filters.cfg for write access"

the filters.cfg file is 0 bytes, and after this error its locked.

I've tried rebooting , and it still stays at 0 bytes

Intermittently the server abends while trying to change a filter. Things
seem to get worse if i try and unload filtcfg.nlm - the server practically
dies (anyone else using arcserve will know what i mean) and needs a cold
boot or an alt-shift-shift-esc then Q

Things I've tried -

Looking for this on the novell KB - zip
looking for this on the newsgroups - zip
Running filtsrv migrate - aint gonna work if filters.cfg is 0 bytes ;-(
reboot, edit one filter then look at filters.cfg - it contains all the
packet types, but no filters

Is there any way to do the opposite of filtsrv migrate? ie pull the filters
from NDS into filters.cfg?

I'm assuming there is a corrupt filter in NDS, but how do i identify it (I
have 274 filters)

Am i postponing the inevitable, I'm going to have to delete filters.cfg and
the NDS objects and type them all in again by hand, i know it.

The last trick i have up my sleeve is to restore the NDS objects , don't
have a copy of filters.cfg (schoolboy error)

Help me Obi-Wan, you're my only hope....