I am getting this error on a GWIA install where I copied the domain directory over to the Linux server (SLES 10 SP3 / OES2 SP2) Per the "Moving the GWIA" chapter in Danita's book (which I think is excellent), I got the MTA up and running and installed the GWIA agents. This error occurs right after hitting Next after putting in the Domain Name and Context in LDAP format. Right before this, a dialog box popped up saying there was an error creating the GWIA object.

That actually makes sense since there is already a GWIA object. I changed the permissions on the gwac.dc to 777, but then I got the same error on preamble.all, changed the permissions to 777, etc. and so forth. The permissions would then change back to 555 and around we went.

I have done clean installs of GW 801 on SLES 10 SP3 / OES2 SP2 and not had a problem.

So, my guess is that I have to delete the GWIA object first. I did try that, but in all of the troubleshooting iterations I went through, I'm not sure of exact sequence of events. I even renamed and deleted the GWIA directory on the Linux server and still got the Errno 13.

Of course, if you need to delete the GWIA object that causes a problem if you need to fall back to the NetWare server if there is a problem. Then you need to recreate the GWIA object. Which is what I had to do so I could send this message. (And change the IP address on the MTA!)

So, I recreated the GWIA, recopied the domain directory and tried it again. Same error. (I did not delete the GWIA)

LDAP is fine and Require TLS for simple binds is unchecked.

Regarding the dbcopy on SLES 10 SP3 / OES2 SP2.

I mapped a drive on a VM 2003 server to the NSS volume on the Linux server and opened a DOS prompt and did the dbcopy from the NetWare server to the Linux server. Seems a lot simpler than creating a mount point or doing the dbcopy to a temp directory on NetWare and then using miggui to migrate it over to Linux. Especially for the Post Office which can take hours. It's copied ahead of time and then all you have to do is the /s copy on migration day and you're ready to go. I'm sure the purists are cringing!!

Thanks very much - BTW, I saw this error posted back in 2006 with no resolution.

Error: 1
IOError Exception in Tk callback
Function: <bound method Config.donext of <gwia.Config instance at 0xb71b862c>> (type: <type 'instancemethod'>)
Args: (<Tkinter.Event instance at 0xb71eb32c>,)
Event type: ButtonPress (type num: 4)
Traceback (innermost last):
File "/media/GW81-Linux/gwinst/python/lib/python2.3/site-packages/Pmw/Pmw_1_2/lib/PmwBase.py", line 1747, in __call__
return apply(self.func, args)
File "/home/build/work/bon/linux_image/groupwise/gwinst/gwia.py", line 478, in donext
File "/home/build/work/bon/linux_image/groupwise/gwinst/utils.py", line 1329, in next
File "/home/build/work/bon/linux_image/groupwise/gwinst/gwia.py", line 596, in createobject
File "/home/build/work/bon/linux_image/groupwise/gwinst/gwia.py", line 613, in CreateObject
File "/root/image/2007.11.09/gwinst/python/lib/python2.3/shutil.py", line 82, in copy2
copyfile(src, dst)
File "/root/image/2007.11.09/gwinst/python/lib/python2.3/shutil.py", line 38, in copyfile
fdst = open(dst, 'wb')
IOError: [Errno 13] Permission denied: '/media/nss/GWDATA/grpwise/bne_dom/wpgate/gwia/gwac.dc'

Event contents:
char: ??
delta: 1
focus: False
height: 0
keycode: 1
keysym: ??
keysym_num: 1
num: 1
send_event: False
serial: 28912
state: 16
time: 562759759
type: 4
widget: .-1222933876.-1222931636.-1222931476
width: 0
x: 43
x_root: 742
y: 18
y_root: 563