I have same issue as some of the other posts for GWIA not being able to get
mail through a BM 3.8SP4 firewall.

Am trying to debug the discarded packets, but the log is filled also with
traffic that appears to be let through. I have turned off all the
forwarding filters with an "= 0". (i.e, "SET TCP FORWARD FILTER = 0").

How do you suppress the "Dynamic rule..." log entries?

The log fills before it can capture any of the discarded packets.

BTW - I drop the filters and SMTP flows properly from external mail sources.