Am going to be doing some CIFS work soonish so though i'd have a play with it, got the domain created and everything looks alright, but can't for the life of me access a share or join a machine to the domain

Server is NW 6.5 SP8

Client is XP SP3 (i've turned off the NTLMv2 in gpedit)

try and join the machine to the domain and get 'unspecified network error ocured'... very helpful Microsoft...

on my NMAS trace I get the following:

13:07:18 95CDF580 NMAS: 55: Create thread request
13:07:18 95CDF580 NMAS: 55: Using thread 0x869cfa40
13:07:18 95CDF580 NMAS: 55: Server thread started
13:07:18 95CDF580 NMAS: 55: Proxy client started local server session
13:07:18 8CC8F5A0 NMAS: 53: ERROR: -1645 Server timed out waiting for data
13:07:18 8CC8F5A0 NMAS: 53: Server thread exited
13:07:18 8CC8F5A0 NMAS: 53: Pool thread 0x869cf900 work complete
13:07:18 95D40280 NMAS: 55: Pool thread 0x869cfa40 awake with new work
13:07:18 95D40280 NMAS: Accessing local replica of Security
13:07:18 95D40280 NMAS: Accessing local replica of CN=Login Policy.CN=Security
13:07:18 95D40280 NMAS: 55: CanDo
13:07:18 95D40280 NMAS: 55: No client network address
13:07:18 95D40280 NMAS: 55: Selected requested login sequence == "Windows Native File Access"
13:07:18 95D40280 NMAS: 55: Login Method 0x00000022
13:07:18 95D40280 NMAS: 55: Begin Server Module 0x00000022
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Read
13:07:18 95CDF580 NMAS: 55: Begin Client Module 0x00000000
13:07:18 95CDF580 NMAS: 55: Client Module 0x00000000 Write
13:07:18 95CDF580 NMAS: 55: Client Module 0x00000000 Read
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Write
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Read
13:07:18 95CDF580 NMAS: 55: Client Module 0x00000000 Write
13:07:18 95CDF580 NMAS: 55: Client Module 0x00000000 Read
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Get Password
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Write
13:07:18 95D40280 NMAS: 55: Server Module 0x00000022 Successful
13:07:18 95CDF580 NMAS: 55: Client Module 0x00000022 Finished
13:07:18 95D40280 NMAS: 55: WhatNext
13:07:18 95D40280 NMAS: 55: Successful login
13:07:18 95D40280 NMAS: 55: Acknowledge
13:07:18 95CDF580 NMAS: 55: Connection identity set successfully
13:07:18 95CDF580 NMAS: 55: Client Session Destroy Request
13:07:18 95D40280 NMAS: 55: ERROR: -1645 Server timed out waiting for data
13:07:18 95D40280 NMAS: 55: Server thread exited
13:07:18 95D40280 NMAS: 55: Pool thread 0x869cfa40 work complete

I've got the name of my domain, cifs server and netware server in hosts on the server and client, not sure if i'm missing any other required DNS entries as the docs don't say I need anything else

Have got universal password set up on my test users as well as an administrator account I created in the domain subtree, i've set the administrator account to be security equivalent of admin so there shouldn't be a rights issue?

If I installed cifs PDC using admin account, do I need to enable universal password on this account as well?