Hi Guys

I have a servere here where some packages are screwed up, I'm not really sure how it happened, I just discovered it yesterday.

If I do an online update, it complains that libzypp and a couple of other things are broken, if I try to 'renew' them with softwaremanager it tells me that it needs to delete a lot of things to resolve the dependencies (amongst those are nss!).
It's a vmware machine which is dedicated to a GroupWise PO.
So as far as I can see I have two possibilities, neither are attractive.

1) Upgrade to SP2/3 and hope that will fix the problems.
2) Reinstall the OS.

I'm not sure what will happen with 1) when the current state is broken, will it even accept the update???

With solution 2, my plan was:
a) save the edir/nici (which folders apart from /etc/opt/novell/eDirectory, /var/opt/novell/eDirectory and /var/opt/novell/nici are necessary?).
b) Delete the disk holding the OS (the GW is on a seperate disk).
c) Install a fresh OES2Sp2 with the same hostname/IP
d) copy the edir/nici back in.

I would prefer 1) if it's feasable, but if not I just want to use solution 2 and keep the servers identity in edirectory.

Anybody that has done the same?