OK, so I setup a Policy server (in DMZ) and a Management server (on LAN) on Win2k3. No problems so far. Everything appears fine but it's hard to tell with the lack of interactivity of the server side services.

Installed the 4.1 security client on Win7 Pro x86, set it up to be "Managed through ESM servers" during setup and configure it to take a user-based policy from the URL supplied. The clients can surf to my supplied internal managerment server URL fine, name resolution works and the IIS instance looks good to me.

After installation of the client I reboot the machine and nothing regarding ZESM is running at all. Nothing in the systray, but all of the binaries are where they should be in "program files\novell\Zenworks security client". The service is in service manager but isn't started, when I try to kick it off manually it fails with a "Error 1053: The service did not repsond to the start or control request in a timely fashion". The app appears completely broken. I've tried and tried and rebuilt a bunch of machines to try to get it to install correctly, but nothing works so far.

In the 4.1 documentation is states...

Novell Documentation

What does any of this mean? Does "Enforce Security Client update policy" mean I can't push policies to the machines? Does the ZESM 4.1 client on Win7 support having it's policies pushed from a server? Where can I look to start troubleshooting anything? I really hope Win7 can have it's policies pushed via a server or I might as well scrap this whole project.


As a side note, there is another issue I've seen specifically with the installation of the 4.1 security client on Win7. It takes FOREVER. Like 20 minutes or so of it just sitting there near the end of the progress indicator doing nothing. I tried to install with a created MSI and it's the same deal. I then installed the MSI using msiexec's commands for verbose logging and saw something interesting in the resulting log. There is a ton of custom actions being called by the MSI near the end of the installation, the thing is it was taking 45 seconds for each individual custom action to complete then move on to the new custom action. I have removed anti-virus and other software from the machines to try to resolve it but nothing has helped at all thus far. I'm at a loss and honestly don't know what to try next. (Also, I just tried to install the client not on my corporate load but instead on a vanilla load built with the official DVD, same exact thing happens.)

Perhaps it's possible that whatever the issue is with the long installation time of the client is related to my issue with the client being non-functional?

Has anyone here done any work at all with the ZES 4.1 client an Windows 7?

If anyone can help or offer any advice on my issues I'd greatly appreciate it. Thanks.