Trying to test AFP on OES2SP2 Linux server. I did the install of AFP as part of the OES install and checked to make sure the files were created after the install.

I ran YAST2 and patched.

In iManager I configured the volume names, and the context for the users, but it errors out after the install.

I saw several posts on AVAHI.daemon as causing troubles and tried killing it and starting AFP, but the service is still not starting.


Logs:

Mar 24 11:03:27 serpent afptcpd[9581]: [debug] 1 _ADMIN
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] 2 DATA
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] SYS is not part of the list of volumes to be exported by AFPServer.
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] _ADMIN is not part of the list of volumes to be exported by AFPServer.
Mar 24 11:03:27 serpent afptcpd[9581]: [status] Directory Caching successful for Volume - DATA
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] zAFPCreate: zCreate failed for DESKTOP.AFP with error - 20412 <4fbc>
Mar 24 11:03:27 serpent afptcpd[9581]: [status] DESKTOP.AFP was created OK (or already exists.)
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] zAFPCreate: zCreate failed for DESKTOP.AFP/APPL with error - 20412 <4fbc>
Mar 24 11:03:27 serpent afptcpd[9581]: [status] DESKTOP.AFP/APPL was created OK (or already exists.)
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] OpenAppl: calling OpenFolder(DESKTOP.AFP/APPL)
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] PopZids: calling zGetInfo( key=90b8d36a )
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] Application ZID = 180 code 0
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] zAFPCreate: zCreate failed for DESKTOP.AFP/ICON with error - 20412 <4fbc>
Mar 24 11:03:27 serpent afptcpd[9581]: [status] DESKTOP.AFP/ICON was created OK (or already exists.)
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] OpenIcon: calling OpenFolder(DESKTOP.AFP/ICON)
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] PopZids: calling zGetInfo( key=ea80509e )
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] PopZids : Icon ZID = 181 rc 0
Mar 24 11:03:27 serpent afptcpd[9581]: [status] Loading of NCP id library is successful
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] **** Rebuilder Thread Started ****
Mar 24 11:03:27 serpent afptcpd[9581]: [debug] Adding service 'serpent'