So I updated my non-important OES to OES2 SP2
Upgrade went well

Now it time for update, here comes rug...

All if fine, correct catalogs subscribed, updates visible, so I jump & lets
update all (as I have no clue what is/not needed)

And the output is below.

Now I am even more puzzled than before as nothing actually gets updated

Seb

plone:/usr/bin # rug up -t patch SLES10-SP3-Updates OES2-SP2-Updates
Resolving Dependencies...

ERROR: Dependency resolution failed:
Unresolved dependencies:
Updating java-1_5_0-ibm-alsa-1.5.0_sr10-0.6.1.i586[System packages] to
java-1_5_0-ibm-alsa-1.5.0_sr11-0.4.1.i586[SLES10-SP2-Updates]
java-1_5_0-ibm-alsa-1.5.0_sr11-0.4.1.i586[SLES10-SP2-Updates] needed by
java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates]
Establishing
atom:java-1_5_0-ibm-alsa-1.5.0_sr11-0.4.1.i586[SLES10-SP2-Updates]
java-1_5_0-ibm-1.5.0_sr11-0.4.1.i586[SLES10-SP2-Updates] provides
java-1_5_0-ibm == 1.5.0_sr11-0.4.1, but another version of that package is
already installed.
There are no installable providers of java-1_5_0-ibm == 1.5.0_sr11-0.4.1 for
java-1_5_0-ibm-alsa-1.5.0_sr11-0.4.1.i586[SLES10-SP2-Updates]
Establishing atom:java-1_5_0-ibm-alsa-1.5.0_sr7-0.2.i586[System packages]
Installing patch:slesp3-java-1_5_0-ibm-6741-0.noarch[SLES10-SP3-Updates]
atom:java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates] needed by
patch:slesp3-java-1_5_0-ibm-6741-0.noarch[SLES10-SP3-Updates]
Installing atom:java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates]
java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates] needed by
atom:java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates]
Updating java-1_5_0-ibm-1.5.0_sr10-0.6.1.i586[System packages] to
java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates]
Establishing atom:java-1_5_0-ibm-1.5.0_sr11-0.4.2.i586[SLES10-SP3-Updates]
java-1_5_0-ibm-1.5.0_sr10-0.6.1.i586[System packages] provides
java-1_5_0-ibm == 1.5.0_sr10-0.6.1, but is scheduled to be uninstalled.
java-1_5_0-ibm-1.5.0_sr10-0.6.1.i586[SUSE Linux Enterprise Server 10 SP3]
provides java-1_5_0-ibm == 1.5.0_sr10-0.6.1, but another version of that
package is already installed.
Can't satisfy requirement java-1_5_0-ibm == 1.5.0_sr10-0.6.1 for
java-1_5_0-ibm-alsa-1.5.0_sr10-0.6.1.i586[System packages]
Establishing atom:java-1_5_0-ibm-1.5.0_sr7-0.2.i586[System packages]

plone:/usr/bin #