I have tried to apply the 10.2.2 update and get the following error:

The Update for ZCM (10.2.2) update requires the following update(s) to be applied before it can be deployed:

Support Pack 2 for ZCM (10.2).

This service pack has been applied to the server already. The server is version

My clients of 1300+ notebooks is running a variety of versions.

If it is true that I need to be baselined; ie: all clients and servers on 10.2 is is never going to happen. Some clients will never check in.

Can someone confirm I need to be baselined, and if so what can I do ?

Please do not suggest I delete registerred devices. They are difficult enough to register without deleting them.