The instructions for 10.3 say that you should delete all outdated updates from a system before downloading and installing 10.3. I did that and now I get the following message when I try to deploy 10.3?!

The Update for ZCM (10.3.0a)
update requires the following update(s) to be downloaded and authorized before it can be deployed:
Support Pack 2 for ZCM (10.2)

My system is running 10.2.2 and all of my clients have been updated and the update was baselined prior to starting.