We have been using GWSOAP for quite a long time on our Groupwise 7.0.3 servers without any problems. Recently we upgraded the servers to 7.0.4. Since the upgrade we see the Groupwise server sending intermittent HTTP/1.1 500 responses, these are very random and sometimes even happen in between the posting the HTTP headers and sending the xml message body.

Sometimes a request gets through normally and we get a SOAP response, but more often than not we just get the 500 error and the connection is slammed shut by the server.

This not only affects our homebuilt SOAP applications, but also connecting with Evolution using the SOAP interface is not working most of the time.

Has anyone else seen this behavior with the new SP4 for Groupwise 7?


Some traces:

Code:
CLIENT REQUEST:
POST /soap HTTP/1.1
SOAPAction: createCursorRequest
Host: xxx.xxx.xxx.xxx:7191
Content-Type: text/xml; charset=UTF-8
Content-Length: 502

<?xml version="1.0" encoding="UTF-8" ?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header><gwtype:session xmlns:gwtype="http://schemas.novell.com/2005/01/GroupWise/types">E4OHycsPbMKWKm9T</gwtype:session></soap:Header><soap:Body><gw:createCursorRequest xmlns:gw="http://schemas.novell.com/2005/01/GroupWise/methods"><gw:container>7.UDOM.PO01.100.0.1.0.1@16</gw:container><gw:view>subject created from status</gw:view></gw:createCursorRequest></soap:Body></soap:Envelope>

SERVER RESPONSE:
HTTP/1.1 500 
Date: Wed, 07 Apr 2010 12:13:03 GMT
Server: Linux GroupWise POA 7.0.4
Content-Type: text/html
Pragma: no-cache
Code:
CLIENT REQUEST:
POST /soap HTTP/1.1
SOAPAction: loginRequest
Host: xxx.xxx.xxx.xxx:7191
Content-Type: text/xml; charset=UTF-8
Content-Length: 621

<?xml version="1.0" encoding="UTF-8" ?><soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/"><soap:Header /><soap:Body><gw:loginRequest xmlns:gw="http://schemas.novell.com/2005/01/GroupWise/methods"><gwtype:auth type="types:TrustedApplication" xmlns:gwtype="http://schemas.novell.com/2005/01/GroupWise/types"><gwtype:username>xxxxxx</gwtype:username><gwtype:name>XSP Trusted App</gwtype:name><gwtype:key>xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx</gwtype:key></gwtype:auth><application>XSP client</application><gw:userid>false</gw:userid></gw:loginRequest></soap:Body></soap:Envelope>

SERVER RESPONSE:
HTTP/1.1 500 
Date: Wed, 07 Apr 2010 11:04:48 GMT
Server: Linux GroupWise POA 7.0.4
Content-Type: text/html
Pragma: no-cache