I have a freshly patched SLES 10 SP2 server that I'm trying to install OES onto. I ask it to install iManager and eDirectory (and the other items that the OES Install tool selects by default).

Towards the end of the install I see some "Failed to install npm" error dialog boxes pop up.

Investigating the y2log, I see:

Code:
2010-04-07 16:12:54 <1> devrdvault01(8205) [YCP] Imanager.ycp:328 iManager:installNPMs: ls command s
un java142 path output: /usr/lib/jvm/java-1_4_2-sun-1.4.2.19/jre/bin/java
2010-04-07 16:12:54 <1> devrdvault01(8205) [YCP] Imanager.ycp:335 iManager:installNPMs: Setting the
JAVA_CMD to the sun path of : /usr/lib/jvm/java-1_4_2-sun-1.4.2.19/jre/bin/java -Xms64m -Xmx96m
2010-04-07 16:12:54 <1> devrdvault01(8205) [YCP] Imanager.ycp:413 iManager:installNPMs:Found files:
["afpmgmt.npm", "BAndR.npm", "cifsmgmt.npm", "dfsmgmt.npm", "fileman.npm", "ncsmgmt.npm", "nssmgmt.n
pm", "iPrint_Linux_iMan27.npm"]
2010-04-07 16:12:54 <1> devrdvault01(8205) [YCP] Imanager.ycp:420 iManager:installNPMs:cmd is: /usr/
lib/jvm/java-1_4_2-sun-1.4.2.19/jre/bin/java -Xms64m -Xmx96m -cp /usr/share/tomcat5https://www.novell.com/common/lib/servl
et-api.jar:/var/opt/novell/iManager/nps/WEB-INF/classes:/var/opt/novell/iManager/nps/WEB-INF/lib/eMF
rame.jar:/var/opt/novell/iManager/nps/WEB-INF/lib/AdminNamespace.jar:/var/opt/novell/iManager/nps/WE
B-INF/lib/rbsCore.jar:/var/opt/novell/iManager/nps/WEB-INF/lib/iManagerModuleInstall.jar com.novell.
application.iManager.install.InstallNPMsOnLinux_OES install /var/opt/novell/iManager/nps/packages/af
pmgmt.npm
2010-04-07 16:12:54 <3> devrdvault01(8205) [bash] ShellCommand.cc(shellcommand):78 Exception in thre
ad "main" java.lang.NoClassDefFoundError: com/novell/application/iManager/install/InstallNPMsOnLinux
_OES
2010-04-07 16:12:54 <1> devrdvault01(8205) [YCP] Imanager.ycp:423 imanager:installNPMs:output:Map Va
lue:
$["exit":1, "stderr":"Exception in thread \"main\" java.lang.NoClassDefFoundError: com/novell/applic
ation/iManager/install/InstallNPMsOnLinux_OES\n", "stdout":""]
2010-04-07 16:12:54 <3> devrdvault01(8205) [YCP] Imanager.ycp:426 Warning: Failed to install npm afp
mgmt.npm
2010-04-07 16:16:05 <3> devrdvault01(8205) [YCP] Report.ycp:484 Failed to install npm
(repeated for each of the npms)

It looks like iManager didn't really install:

Code:
devrdvault01:~ # ls -R /var/opt/novell/iManager/nps/
/var/opt/novell/iManager/nps/:
WEB-INF  packages

/var/opt/novell/iManager/nps/WEB-INF:
configiman.properties

/var/opt/novell/iManager/nps/packages:
BAndR.npm    cifsmgmt.npm  fileman.npm              ncsmgmt.npm
afpmgmt.npm  dfsmgmt.npm   iPrint_Linux_iMan27.npm  nssmgmt.npm
Which is strange, because the rpm is there:

Code:
devrdvault01:~ # rpm -qa |grep imanager
novell-usermanagement-imanager-plugin-2.2.0-38
yast2-novell-imanager-2.13.1-55
novell-imanager-2.7.3-0.4.3
Sure enough, the RPM does not verify:

Code:
devrdvault01:~ # rpm -V novell-imanager |head -10
.M...UGT  c /etc/opt/novell/iManager/nps-Apache.conf
missing     /var/opt/novell/iManager/nps/Browser.html
missing     /var/opt/novell/iManager/nps/DeployedServices.ds
missing     /var/opt/novell/iManager/nps/Empty.html
missing     /var/opt/novell/iManager/nps/META-INF
missing     /var/opt/novell/iManager/nps/META-INF/MANIFEST.MF
missing     /var/opt/novell/iManager/nps/Mozilla.html
missing     /var/opt/novell/iManager/nps/Pocket.html
missing     /var/opt/novell/iManager/nps/Query.html
missing     /var/opt/novell/iManager/nps/Simple.html
I blew away the server and started again, with the same result. I am starting from a partially patched image - but it has worked fine in the past to setup eDir/iManager installs, so it seems like a patch Novell has released recently may be causing the issue.

Any thoughts?

-james