I am trying to Image a Linux workstation with ZCM 10.3

The Linux OS is Cent OS 5.3

I have 2 Identical machines that I am testing this with, I have got one machine up and running. Then proceeded to take the Image and send it to ZCM Imaging.

When I go and dump the Image to a 2nd Identical hardware box it ends up coming with Grub Error 2. I have tried applying the image back to the machine I based the image off of as well and it comes up with the same error.

Grub Error 2 is:
"Selected disk doesn't exist"
This error is returned if the device part of a device- or full filename refers to a disk or BIOS device that is not present or not recognized by the BIOS in the system

When I boot up a linux System rescue CD and look at the partitioning of the drive all appears fine.

fdisk l /dev/hda
Disk /dev/hda: 33.8 GB, 33820286976 bytes
255 heads, 63 sectors/track, 4111 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000cff34

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         625     5020281   83  Linux
/dev/hda2            1025        1132      867510   82  Linux swap / Solaris
Does any one have any other Ideas on what I could do to make this work.. Any Extra flags to add when taking the Image?