If I use Migration Wizard 8.2 to migrate NetWare 6.5 sp6 or sp7 servers to NetWare 6.5 SP8, must the source servers have eDirectory 8.8.4 on them prior to the migration?

I ask because the Migration Wizard's readme says:
"IMPORTANT: If you are migrating to a NetWare 6.5 SP7 server with eDirectory 8.8, you must first upgrade to eDirectory 8.8 SP2 (the default for a new install of NetWare 6.5 SP7) prior to migrating. Failure to do so will result in "Edirectory 8.8 Migration fails, edir fails to load properly with -6061 nici" errors."

Apparently this was written before SP8 was released. But it appears to be saying that my source server must be the same eDir version as my target server. And since my target server will have eDir 8.8.4, I wonder if my source server needs it.