I am having problems trying to connect a user to a NetWare cluster AFP share from a MAC running OS X (10.6) - the cluster node is fully patched to SP8, edir SMB. I am logged is a admin user on the MAC.

If I run "connect to server" from the MAC using a test eDirectory account (with admin rights to this area) entering the URL, in this case:


It then prompts for authentication and I enter the username & password but it continually says this is incorrect and I can get no further (simple password is configured).

We currently have MAC users (using a non-clustered NetWare server with an AFP share) which works fine without issues.
I have therefore tried to replicate this, and with this test user (and my own) I can at least get to the point where the volumes are presented, however the final stage of "seeing" the NSS volume again fails on authentication. I can authenticate elsewhere with this user, so know the eDir password is right.

The clustered server in question has a replica, and the test user object I am trying to connect using is on this replica.

If I try and connect as myself to the clustered volume, I can authenticate and see a list of the volumes; but I am still unable to actually further access the volume.

I found a TID (5059800) with a patch for the afptcp.nlm and it has been applied to the clustered server, but still no difference.

I have run a DSTRACE on the netware server and it can see the authentication of the eDir user and it says it's successful!

Thanks in advance,