I'm having a bit of a fight with the ZenWorks 10 Agent and my ability to deploy bundles when I really want to... but here's the situation...

The bundle in question upgrades a workstation to Novell Client 4.91 SP5 with the post-service pack patches. Details about the bundle:
  • Under Requirements it checks to see if HKEY_LOCAL_MACHINE\SOFTWARE\Novell\NetWareWorkstat ion\CurrentVersion\Service Pack is less than 5.
  • Under Install it uses End Process on nwtray.exe and nwlscrpt.exe in case the Results screen is left open, then it launches the ACU.exe from the Novell Client install source.
  • Under Relationships I have Workstations added under Device Assignment and the Assignment Details is set to Event and User Login with "Install Immediately after Distribution" and "Launch Immediately after Installation" both checked. It also shows up in Start Menu. **I'm removing this now, just in case it was the issue.

Those are all the details of the bundle. I'm not sure if the Start Menu thing had anything to do with it, but after having it running since last week I see only three devices have succeed and eleven are pending. I've been researching this since last week and only found this post about it to which no one replied:


I tried to use the Bundle Status feature and force the install, but I just get Failed and Connection Failed on these machines. Maybe this feature requires the machines to be online?

My big question is why do they get stuck in a pending state? Some of them I'm remoted then manually refreshed the box and the install started right then. I've tried refreshing all devices via the ZCC and did not get the same result.

Should I not be using User Login? I had previously tried on Refresh and after seeing the same result I tried User Login. In ZenWorks 7 we only ever used on refresh.