Hi
I'm just trying to establish the correct method for setting the noatime (and apparently non existent nodiratime) for volumes within a cluster resource (will be GW resource)

I have tried in the load script
e.g. exit_on_error ncpcon mount /opt=ns=unix,noatime WMGW=251
but this doesn't appear to set it (at least looking at nsscon nss /volumes)
However, this does appear in the /etc/mtab file...
>...
WMGW /media/nss/WMGW nssvol rw,noatime,name=WMGW,ns=unix 0 0
<

It can be set manually in nsscon, and this may be persistent... is it? If so where? Is this an attribute of the volume itself? i.e. will it be ok on all cluster nodes
Does /etc/opt/novell/nss/nssstart.cfg have any relevance?

>>
wmlx-1> volumes
Volume Name State Attributes
----------------------- ----------- -----------------------------------
_ADMIN ACTIVE Hardlinks
WMDATA ACTIVE Salvage
COMMON ACTIVE Salvage
WMAPPS ACTIVE Salvage
WMIPRINT ACTIVE Salvage
WMDHCP ACTIVE Salvage
WMGWREST ACTIVE
WMGW ACTIVE
wmlx-1> nss /noatime=WMGW
File Access Time disabled on volume "WMGW"...
wmlx-1> volumes
Volume Name State Attributes
----------------------- ----------- -----------------------------------
_ADMIN ACTIVE Hardlinks
WMDATA ACTIVE Salvage
COMMON ACTIVE Salvage
WMAPPS ACTIVE Salvage
WMIPRINT ACTIVE Salvage
WMDHCP ACTIVE Salvage
WMGWREST ACTIVE
WMGW ACTIVE No Access Time
wmlx-1> nss /nodiratime=WMGW

May 5, 2010 9:49:42 am NSS<NSSLIB>-4.12a-212: pcmdline.c[743]
Option "/nodiratime=WMGW" is unknown for the current NSS configuration
and may require other NSS modules to be loaded.

<<

I've looked through the forum posts and little documentation there is, but this mainly deals with fstab, on standalone boxes - not ncs

So, how's it best done?!?

Also, what's the deal with nodiratime? It's in the nss doc, but not the nsscon help and (as above) we get an error when trying to set it...

Thanks

David