how can I deploy the Agent only to Workstations which have the Novell Client 4.91 SP5 installed?

It is NOT possible to create a bundle for updating the Agent

It is NOT possible to assign the ZCM Agent to dynamic Workstation Groups

Why can't I assign stages to dynamic groups? Why not deploy the Agent to dynamic groups?

It is NOT possible to distribute the Agent only on PCs with specific Requirements

We have the issue that the new Agent requires the Novell Client 4.91 sp5. Otherwise I have NO login with the SP3 Client after ZCM Agent update.

And the update to the new client will take a couple of weeks!

I am getting frustrated. Each day another annoyance!